まつもと ゆきひろです

In message "Re: [ruby-list:40501] getopt"
    on Sun, 9 Jan 2005 02:45:29 +0900, keiju / ishitsuka.com (Keiju ISHITSUKA) writes:

|emperor% ruby -e "require 'getopts'"
|Warning:-e:1: getopts is deprecated after Ruby 1.8.1; use optparse instead
|
|getopts.rb は非推奨品になったということでしょうか? 

そういうことです。

|とはいえ, optparse って随分インターフェイスが変わっていて戸惑ってしま
|うのですが...

とはいえ、グローバル変数を多用したgetoptsを今さら推奨するっ
てのもねえ。

|あと, getoptlong.rb もあると思いますが, それも推薦品ではないってことで
|しょうか?

そうですね。どっちかといえばoptparseを勧めたいって感じです。