けいじゅ@いしつかです.

久々にrubyをバージョンアップしたのですが...

ruby 1.8.2 (2005-01-08)でですが,
autoloadのインターフェイス変わりました?

autoload :symbol, "XX.rb"

でエラーが起るようになっているのですが?

emperor% ruby -e 'autoload :Foo, "foo.rb"'
-e:1:in `autoload': wrong argument type false (expected Class) (TypeError)
        from -e:1

ちなみに, 1.9系ではだいじょうぶなようです.

__
---------------------------------------------------->> 石塚 圭樹 <<---
---------------------------------->> e-mail: keiju / ishitsuka.com <<---