こんにちは。三並です。

ActiveScriptRuby 1.8.2.0が公開されていたので、
早速試したところ、使ってみました。

いろいろと試していたら、ひょんなところで落ちたので、
とりあえず報告をさせていただきます。

vrubyサンプルのaxtest.rbを動かしたところ、
以下のようなエラーが出ました。

----
D:\>ruby axtest.rb
C:/Program Files/ruby-1.8/lib/ruby/site_ruby/1.8/vr/vractivex.rb:38:in
`get_olei
nterface': This win32ole(0.5.9) is not acceptable(version mismatch).
(NotImpleme
ntedError)
        from C:/Program
Files/ruby-1.8/lib/ruby/site_ruby/1.8/vr/vractivex.rb:38
:in `vrinit'
        from C:/Program
Files/ruby-1.8/lib/ruby/site_ruby/1.8/vr/vruby.rb:128:in
 `create'
        from C:/Program
Files/ruby-1.8/lib/ruby/site_ruby/1.8/vr/vruby.rb:544:in
 `vr_addControlOriginal'
        from C:/Program
Files/ruby-1.8/lib/ruby/site_ruby/1.8/vr/vrlayout.rb:113
:in `addControl'
        from axtest.rb:12:in `construct'
        from C:/Program
Files/ruby-1.8/lib/ruby/site_ruby/1.8/vr/vruby.rb:514:in
 `_vr_call_created'
        from C:/Program
Files/ruby-1.8/lib/ruby/site_ruby/1.8/vr/vruby.rb:129:in
 `create'
        from C:/Program
Files/ruby-1.8/lib/ruby/site_ruby/1.8/vr/vruby.rb:955:in
 `showForm'
        from C:/Program
Files/ruby-1.8/lib/ruby/site_ruby/1.8/vr/vruby.rb:961:in
 `start'
        from axtest.rb:28

D:\>ruby -v
ruby 1.8.2 (2004-12-25) [i386-mswin32]
----

一応、
http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-list/40158
のパッチは当ててあります。

エラーメッセージが出ているとおりのことだと思うのですが、
対処法などはわからなかったので、報告だけになってしまいました。

では。