まつもと ゆきひろです

In message "[ruby-list:39870] Re: イテレータとfor文"
    on 04/07/21, Nowake <nowake / fiercewinds.net> writes:

|・そもそもイテレータという名前が良くない。概念的にはもっと広い
|  「名前のない関数を引数とするメソッド呼び出し」といったようなものなので
|  メソッド的な表記にしている

だから、最近はイテレータと呼んでいません。正式(?)な名称は
「ブロック付きメソッド呼び出し」ですね。

|個人的にはもっとメソッド定義の記法と共通化したほうが好みですけどね。
|大谷さんの例だとこんな感じですか。あまりかっこよくないですが……
|
|IO.foreach("filename") def (line) 
|  puts line
|end

「名前のない関数」はRubyの文法にはないので、「def」はあんま
りよくないですかねえ。