なかだです。

At Wed, 20 Aug 2003 20:32:32 +0900,
Nobuyoshi-Nakada wrote:
> > 現状では、やはり最初のパッチのように自前でチェックするしかなさそ
> > うなので、そのようにしたものを0.6としてリリースしました。
> > RAAに登録してあります。
> 
> わたなべさんのブロックを使うという案でいってみました。

入れてみました。

> これだと、have_libwrapはこういう形になります。
> 
>   def have_libwrap
>     have_library("wrap"){|src|src+"int allow_severity, deny_severity;"}
>   end

順序が問題になる場合は、#includeの後に/*top*/という行が入るので、
このようにしてください。

    have_library("wrap"){|src|
      src.sub(%r"^(?=/\*top\*/)", "int allow_severity, deny_severity;\n")
    }

-- 
--- 僕の前にBugはない。
--- 僕の後ろにBugはできる。
    中田 伸悦