前田です。

At Tue, 12 Aug 2003 21:15:32 +0900,
Kazuhiko <kazuhiko / fdiary.net> wrote:
> ruby-1.8 にしてから let me see... (http://openlab.jp/edict/letmesee/) が
> 以下のように動かなくなったために気づいたのですが、
> 
> [error] [client 127.0.0.1] Premature end of script headers: index.rb
> [error] [client 127.0.0.1] failed to open log file
> [error] [client 127.0.0.1] fopen: Permission denied
> 
> どうも eruby で cgi がうまく動かなくなっているようです。

まず、eruby-1.0.3はruby-1.8に対応していません(makeできたんだっ
け)ので、CVSの最新版をご利用ください。

それと、CGI.newの内部で、環境変数REQUEST_METHODが設定されていない
時にはreadlinesを呼ぶようになっていますが、$stdoutがIOでない時に
ruby側のバグでエラーになっていました。
rubyのCVSのHEADに修正をcommitしてありますので、合わせてご利用くだ
さい。

-- 
前田 修吾