皆さん、こんにちは。佐野と申します。

スクリプトの中でJcodeとYAML.rbを使いたいと思っているのですが、
どうもこの両者を組み合わせるとエラーが出ます。Jcodeのエラー
発生場所を見てみたのですが初心者の私にはどうもよくわかりません。
なにが原因でこうなってしまうのでしょうか?

アドバイスよろしくお願いします。

実行環境:
WindowsXP
ruby 1.6.8 (2002-12-24)[i586-mswin32]
YAML 0.492

実行スクリプト
--- test.rb ---
require 'jcode'
require 'yaml'
path = 'test.yml'  
configfile = File.open(path)
config = YAML.load(configfile)
configfile.close
---

スタックトレース
--- stack trace
c:/ruby/lib/ruby/1.6/jcode.rb:150:in `delete!': premature end of regular 
expression: /[]+/ (RegexpError)
	from c:/ruby/lib/ruby/1.6/jcode.rb:154:in `delete'
	from src/emitter.rb:1079:in `plain_re'
	from src/yaml.y.rb:154:in `initialize'
	from src/emitter.rb:845:in `new'
	from src/emitter.rb:845:in `load'
	from C:\home\test.rb:6
---

佐野剛史