新井です。

In message "[ruby-list:36501] Re: cacheout.rb"
  on 17 Nov 2002 08:10:40 +0900,
  matz / ruby-lang.org (Yukihiro Matsumoto) wrote:
> まつもと ゆきひろです

> で、せっかくなので本家にマージするとか。ファイル名は単に
> cacheだと広すぎるのでfile/cacheとかではどうでしょう?
> となるとクラス名はFileCacheじゃなくてFile::Cacheのほうが良い
> のかなあ。

おくじさんのライブラリの方は用途の広いものなので、cache.rb 
でも良いかと思います。最近使用したものにだけ用のある Hash。
なんとなく語呂がいい。

filecache の方は、うーん perl に敬意を表してやっぱり 
cacheout.rb CacheOut かなあ、出力だけだし。

むしろ cache かどうかを意識しない名前が良いかもしれませんね。
AnyOpenFile とかなんとか。(ださ)

--
新井康司 (Koji Arai)