まつもと ゆきひろです

In message "[ruby-list:36447] require中の$SAFE"
    on 02/11/12, Kazuhiro NISHIYAMA <zn / mbf.nifty.com> writes:

|requireされたファイルの中で $SAFE=0 になるのは仕様なのでしょうか?

はい。