まつもと ゆきひろです

In message "[ruby-list:36311] Re: ar=[];ar+=2でエラー"
    on 02/11/04, 堀川 久 <vzw00011 / nifty.ne.jp> writes:

|私の希望は,パース時に「初期化されない可能性がある」エラーか,実行時
|(実際に'p v'の行を通過するとき)に「初期化されていない」エラーにして
|ほしい,ということです。

Javaみたい。でも、実装が大変(可能な実行パスを解析する必要が
あるから)わりには嬉しいことが多くないように思います。