前田です。

At Tue, 18 Jun 2002 00:45:25 +0900,
J.Meguro <meguro / yggdrasil.jp> wrote:
> > なかださんのパッチはconfigure.rb.inのもので、configure.rbは更新さ
> > れないからじゃないかと思います。
> > 添付するパッチでどうでしょうか?
> > 
> どうもありがとうございます。これでOKになりました。
> でも、Apache2ではstatic moduleは未対応なんですよね?

そうでした(忘れていました)。

> > --with-apxsはDSOモジュールを作る時に、--with-apacheの方はApacheに
> > 静的に組み込む時に使いますので、どちらか片方を指定してください。
> > 
> > また、--with-apacheで指定するディレクトリはApacheのソースが展開さ
> > れているディレクトリです。
> 
> これは、完全に私が勘違いしていますね。お恥ずかしい。
> マニュアル読んで出直してきます。

紛らわしいので両方指定したらエラーになるように変更しようと思います。

> 勝手ながらApache2とmod_rubyについてまとめると、こんな感じでしょうか?
> 
>  ・Apache2にmod_rubyは動的モジュールのみで動作
>  ・mod_rubyをconfigureするとき、静的モジュールは有効にしない方がいい
>  ・Apache2ではAPIが異なる部分があるため一部のメソッドが利用できない
>  ・静的モジュールを使わないことが前提ならば、なかださんと前田さんの
>   patchがなくても大丈夫
>  ・patchをあてるとApache2で--with-apacheオプションをつけてもconfigureが
>   止まらなくなる

はい、そうです。
1.0.0では静的モジュールにすることもできるようにしたいと思います。
# 何か問題がなければ。

> #mod_ruby 1.x が待ち遠しいです。

新しいfeatureを追加した、Apache1でも動くバージョンが欲しいと言わ
れているので、

1.1.x: Apache1/Apache2対応の開発版
1.2.x: Apache1/Apache2対応の安定版
1.3.x: Apache2専用の開発版

といった感じになるかもしれません。

-- 
前田 修吾