わたなべです。

TAKAHASHI Masayoshi <maki / inac.co.jp> writes:

:とある方から、sparc版の古いSunOS(4.1.3)でRuby 1.6.6がコンパイル
:できない、という連絡がありました。
:
:サポートしているSunOSのバージョンはいくつまで、という明示的な
:制限ってあるんでしょうか。
:
:いただいたmakeのログとconfigureのログを以下に添付します。

これに関してはstructにstaticをつければ通ると思いますが、
その他新しく導入されたものの中にはANSI styleで書かれたものが
入っているので、たぶんそこでもエラーになります。
つまり事実上古いK&R1 styleのccは対象外となりました。
[ruby-dev:16736] を参照。

-- 
わたなべひろふみ