まつもと ゆきひろです

In message "[ruby-list:35265] Re: ((1.2)..(3.4)).to_a"
    on 02/05/27, Take_tk <ggb03124 / nifty.ne.jp> writes:

|> で、「疑問」ということで、どうあれば「疑問」を感じませんか?
|
| むしろ単純に Float#succ を self+1 で定義して
|
|p ((1.2 .. 3.4).to_a )
|    => [1.2, 2.2, 3.2]
|
|となる方が自然のような気がしてきました。実数の範囲を単位で分割すれば、や
|はり実数で返るべき。整数の配列が欲しければ利用者側で ceil floor した範囲
|を与えればよい。

うーん、

|実数の範囲を単位で分割すれば、や
|はり実数で返るべき。整数の配列が欲しければ利用者側で ceil floor した範囲
|を与えればよい。

という主張には同意できるんですが、Floatのsuccってのはかなり
気持ち悪いです。