ふなばです。

衝突の件は、やはり、名前を統一する (date2.rb は date.rb、のように名前
を変更する)、ということで回避しようと思います。それで、もし、どうして
も、require 'date2' としたい、という人がいたら、date2-compat というも
のを用意するので、それもインストールしてもらう、ということにしようと思
います。とくに何もなければ、明日あたり、あたらしいの出します。