小西 弘将です。

つい最近、ruby-win32 / moonwolf.comの方で下のような話がありました。
もしさしつかえがなければ、名前を変えてもいいと思うのですが。
その場合、変更後の名前さえ確定できれば、パッチの作成作業は私がやりたいと
思うのですが、どうでしょうか?

> > > >つまんないことですが、最近よく聞くアプリケーションへの組み込み
> > > >を考えると、my*という名前は避けたほうがいいと思います。
> > > >win32/win32.cのwin32_*というのも失敗だったと思ってます。
> > > そうすると1案としては、
> > > 
> > >   my_* or win32_*  -> rb_w_* or rw_*
> > >   
> > > という具合でしょうか(それとも rbw32_*?)
> > 
> > ruby_* と rb_* の使い分けってのをどこかで見た記憶があるので
> > すが、どんな内容だったかなぁ。
>
>ruby_は内部仕様、rb_は外部(拡張ライブラリとか)用かなと思ってま
>すが。
>
> > というのはともかく、rb_w32_* くらいがいいかと思いました。
>
>そうですね。Windows限定のもの以外は、すでに使われているのでなけ
>れば、ruby_*でいいような気もしますが。あとは、Nt*はInitialize以
>外は全部staticにして構わないんじゃないかとか。

rb_w、rw_、rbw32_あたりは私が出しているのですが、個人的にはrb_w32_がわか
りやすくていい気がします。

#〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜
# 小西 弘将 ( KONISHI Hiromasa )
# konishih / fd6.so-net.ne.jp
#〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜