なひです。

> From: Tadayoshi Funaba
> Sent: Wednesday, May 08, 2002 12:28 AM

> newdate (仮) の最初の段階では、date2.rb という名前はやめようと考えてい
> たのですが、[ruby-list:34377] で、やはり date2.rb にしてほしい、という
> ことがあって、そのようにしました。
> 
> しかし、衝突はよくないので、今更だけど、date2.rb は date.rb に改めよう
> か、とも考えています (あるいは、両方で参照できるようにする)。この問題
> は、[ruby-list:34377] の懸念よりも重い、という判断です。

了解です。↑の判断に同意します。

この場合、

1.7→1.8では新版が標準添付される予定のため、
衝突はなくなります。が、[ruby-list:34377]の問題が残ります。

1.6では今後もdate2パッケージを使うことになります。
これはdate.rbとしてインストールされるため、
標準添付のdate.rbが読み込まれることがなくなり、
衝突はなくなります。[ruby-list:34377]の問題も起こりません。

現状で、1.7でdate2.rbを使っている人がどれだけ居るというのでしょう。
なひだけだったりして。:)
ともあれ、この方法が一番影響が少ないと思います。

とはいえ、1.7への標準添付は早ければ早いほど嬉しいです。
今は何待ちなのでしたっけ?