違う話題は別のメールにした方が良いかと思います。

In message <F55tLch9wPiyAphwFut00003c35 / hotmail.com>
	on Wed, 13 Mar 2002 10:04:57 +0900,
	"=?iso-2022-jp?B?GyRCMGY+ZRsoQiAbJEI5QDBsGyhC?=" <kyoui32 / hotmail.com> wrote:
> さまざまな拡張ライブラリが存在しますが、インストールした際に、それらが正しく
> インストールされているか、若しくは
> バージョン表示など統一された方法は存在するのでしょうか?
どうやってインストールしたかに依存するでしょう。

自分でソースからインストールした場合:

	自分でソースからやったのだからバージョンはわかってるはず。
	インストールの過程で正しくインストールできたか確認するはず。

パッケージ・ベースでインストールした場合:

> linuxなら rpmでわかりますが、別のプラットフォームは、わかりません。
	パッケージ・システムが存在しているかどうか、というあたりにも
	関わってきます。BSD系のシステムでは、pkg_infoというコマンドが
	あります。

> ruby --extや、 extruby.rb -v など一覧詳細でわかればgoodsです。
正式リリースに含まれている内容を越えた部分に関しては、rubyそのものには
存在しないでしょう。perlにだってない気がします。

--
神戸 隆博(かんべ たかひろ)		at 仕事場