井上
お世話になります。

さまざまな拡張ライブラリが存在しますが、インストールした際に、それらが正しく
インストールされているか、若しくは
バージョン表示など統一された方法は存在するのでしょうか?
linuxなら rpmでわかりますが、別のプラットフォームは、わかりません。既に用の
ような方法があるのでしたら、教えて下さい。
ruby --extや、 extruby.rb -v など一覧詳細でわかればgoodsです。

また、これもWindowst特有ですが、Rubyでこけるとプロセスに残ったままでKILL出来
なくOSに負荷がかかります。
ruby --kamikaze 300  5分で自爆する等で、その間デットロックしたら自ら時限装置
で消滅する機能はないでしょうか?
詳しい仕組みが分からないのですが、一番良いのは暴走したら自爆する仕組みが欲し
いです。
Unix側でもわざわざKILLしなくて済むという手間賃が浮くと思います。


_________________________________________________________________
メールだけじゃなかった!インターネット便利サービスがひとまとまり 
http://explorer.msn.co.jp/