dellinといいます。

「たまてばこ」の開発版1.1.65を使っているのですが、インストール直後の状態だと
SecurityErrorにひっかかります。

利用環境は、自分のLinux-2.4.17マシンのローカルで、ユーザホームディレクトリの
下で使ってます。

ちなみに手元では~/antenna/tama.rbの$SAFEを0に書き換えて使っていますが、
(開発版は自己責任でしょうし)気になりましたので投稿しました。

==エラーメッセージ <<EOM
[dellin@localhost dellin]$ ruby ~/antenna/tama.rb
./lib/antenna.rb:75:in `popen': Insecure PATH - /bin/gzip -dc 
(本当は前の行とつながってる) < /tmp/tama_tmp14241.0 (SecurityError)
	from ./lib/antenna.rb:75:in `read'
	from ./lib/lirs.rb:12:in `open'
	from /home/dellin/antenna/tama.rb:106:in `get_remote'
	from /home/dellin/antenna/tama.rb:101:in `each'
	from /home/dellin/antenna/tama.rb:101:in `get_remote'
	from /home/dellin/antenna/tama.rb:322
./lib/antenna.rb:75: [BUG] Segmentation fault
ruby 1.6.5 (2001-10-05) [i386-linux]
Aborted (core dumped)
EOM

--
dellin  Email dellin / team-ct.org
        WWW   http://priest.team-ct.org/~dellin/