岡田です。

> Rubyのライブラリで以下のファイルはどこから手に入るのでしょうか?
> require 'stringio'
> require 'fcgi.so'

http://fenris.codedogs.ca/~eli/fastcgi.html
stringioはこちら
fcgi.soなるファイルは不要

> Win版では、mod_fasrcgi-2.2.12.dllを使うと思うのですが、
> これをApacheのどのディレクトリに入れるのでしょうか?

http://www.fastcgi.com/mod_fastcgi/INSTALL
WindowsつーてもNT系onlyでしょうか?

まずは落ち着いて深呼吸でもされてはいかがかと思います。

-- 
ゆん(岡田 潤)
yun / be-in.org
http://www.be-in.org/~yun/