まつもと ゆきひろです

In message "[ruby-list:31462] Array#next_of(item)"
    on 01/09/15, "たけ(tk)" <ggb03124 / nifty.ne.jp> writes:

|懲りずにご提案。
|
|    ##  次の要素/前の要素を返す。

|    ##  array[ array.index(item)+1 ]  では undefined method `+' for nil

 (array[array.index(item)+1] rescue nil)

で十分では? 一般にRuby数行で記述できるようなメソッドはよほ
ど意味的に重要でなければ採用しないとおもいます。