高橋征義です。

WebUnit(webunit-20010714-alpha.tar.gz)に入っているhtml-parserの
install.rbが、ruby-1.6.4ではエラーになります。

# [ruby-dev:11702]によれば 2000-11-27から2000-12-05の間で
# 変わったみたいですね。

修正はこんな感じでどうでしょうか。


--- install.rb.org	Tue Sep 11 10:56:50 2001
+++ install.rb	Tue Sep 11 10:57:20 2001
@@ -24,12 +24,12 @@
   dir = []
   if files
     path = files
-    dir |= libdir
+    dir |= [libdir]
   else
     Find.find(libdir) do |f|
       next if (f = f[libdir.length+1..-1]) == nil
       path.push f if File.ftype(File.join(libdir, f)) == 'file'
-      dir |= File.dirname(f)
+      dir |= [File.dirname(f)]
     end
   end
   for f in dir


高橋征義 (TAKAHASHI Masayoshi)       Email:maki / inac.co.jp