安積です。

Okada Jun wrote:
> FreeBSDとrubyの特定バージョン(1.6.2以降)限定バグの模様。
> 他にFreeBSDの方、追試お願いします。

とりあえず NetBSD でも確認。

$ cat test.rb
begin
  raise
ensure
  require 'cgi'
end
$ for ver in 1.4.6 1.6.0 1.6.1 1.6.2 1.6.3; do ruby-$ver -v; ruby-$ver test.rb; done
ruby 1.4.6 (2000-08-16) [i386-netbsd1.5]
test.rb:2: unhandled exception
ruby 1.6.0 (2000-09-19) [i386-netbsd1.5]
test.rb:2: unhandled exception
ruby 1.6.1 (2000-09-27) [i386-netbsd1.5]
test.rb:2: unhandled exception
ruby 1.6.2 (2000-12-25) [i386-netbsd1.5]
ruby 1.6.3 (2001-03-19) [i386-netbsd1.5]

> ruby 1.6.2 (2000-12-25) [i386-netbsd1.5] 
> では再現しなかったそうです。

…あれ?

ちなみに xpg4dl を手で入れた以外は全然いじくって
ない NetBSD1.5/i386 です。

安積伸弥
adzumi / denpa.org