石橋秀仁です。こんにちは。

Takahiro Kambe <taca / sky.yamashina.kyoto.jp> wrote:

> 	incompatible marshal file format (can be read)
> 		format version 4.5 required; 4.4 given
> 
> といった様な表示がなされました。幸い、問題はなかったのですが、
> 
> o Marshalが想定している形式のバージョン情報を得る。
> o Marshalでdumpした内容のバージョン情報を得る。
> 
> といったメソッドがあると嬉しいと思いました。先のケースでは、Marshalで

賛成です。

最近も pragmatic programmer さんが公開した ri (ruby index)
について、 [ruby-talk:11513] のような問題がありました。

Marshal のフォーマットのバージョンについて知らない人は、
地力で解決できないことだと思います。プログラム側で判定して
対処するための仕組みを、 ruby インタプリタ側で用意して
いただけると便利だと思いました。


--
石橋秀仁 hideto-i / rr.iij4u.or.jp
messenger: ICQ# 83329246, MSN hideto_i / hotmail.com, Yahoo! hideto_i