るびきちです。

これはバグでしょうか?
#!/usr/bin/env ruby
require 'importenv'
p $USER
$USER = "matz"
p ENV["USER"]
p $USER          # "matz?"
p RUBY_VERSION

cd /tmp/
/tmp/test.rb
"rubikitch"
"matz"
"rubikitch"   # ???
"matz"
"1.6.2"


るびきち☆
http://www.ruby-lang.org/~rubikitch/