助田です。

In message "[ruby-list:27107] Re: load method"
    on 01/01/14, nobu.nakada / nifty.ne.jp <nobu.nakada / nifty.ne.jp> writes:

>   私の意図はラップされた load の内と外とで分かれるということで
> した。たぶん助田さんの意図も同じじゃないかと思うのですが、どっ
> ちの方がいいのかなぁ。今のではラップされたスクリプトからは他の
> スクリプトを使う際に制限があるけれど、逆にそういうことをすべき
> ではない?

私の意図も同じです。で、個人的にはできた方が嬉しいのですけど
そういうことができちゃうと、逆にどっかでまずい部分があるのか
どうかが自分でも良くわかんないです。

  助田 雅紀