From: "  たけ  (tk)" <ggb03124 / nifty.ne.jp>
Subject: [ruby-list:27023] Array#sum
Date: Sat, 6 Jan 2001 23:44:05 +0900

るびきちです。

> Array#sum ってあっても良さそうではありませんか?。
ずっと前からなんでないのか不思議でしょうがなかったです。
俺は自分でMath.sum(ary)を定義してます。

> form.client_width = edits.sum{ |c| c.width } + 10
そう書けるところがかっこいい!!
だからRubyのイテレータには魅かれてしまうわけです。

るびきち☆
http://www.ruby-lang.org/~rubikitch