Array#sum ってあっても良さそうではありませんか?。

class Array
  def sum
    ret = 0
    if defined? yield
      each{|i| ret += yield(i) }
    else
      each{|i| ret += i }
    end
    ret
  end
end

form.client_width = edits.sum{ |c| c.width } + 10

または

form.client_width = edits.collect{ |c| c.width }.sum + 10

* edits:横に並べるコンポーネントの Array
* c.width:配列に入っている個々のコンポーネントの横幅
* form.client_width:フォームの横幅

たけ(tk) ggb03124 / nifty.ne.jp
http://member.nifty.ne.jp/take_tk