咳といいます。
 
> ruby-1.6.2にしました。
> 次のような警告が出るようになってしまいました。

>   warning: print (...) interpreted as method call
>   warning: concat (...) interpreted as method call

> 対応しないとまずいかな。erbで出してしまぅぅ。

とりあえず、erb-1.3.2 では以下のパッチで警告がでなくなります。
たぶん。数日待って問題が出なければ年明けに 1.3.3 にします。


diff -u -r1.5 compile.rb
--- compile.rb  2000/07/19 16:32:57     1.5
+++ compile.rb  2000/12/28 22:24:00
@@ -66,7 +66,7 @@
          when '<%'
            cmd.push(content)
          when '<%='
-           cmd.push("#{@put_cmd} ((#{content}).to_s)")
+           cmd.push("#{@put_cmd}((#{content}).to_s)")
          when '<%#'
            #     cmd.push('=begin')
            #     cmd.push(content)