わたなべです.

"DATE Ken" <ge6537 / i.bekkoame.ne.jp> writes:

:原因は dllwrap のオプションが
:-L/usr/local/lib -L/usr/local/src/ruby/ruby-1.6.2
:のために古いライブラリを参照しに行ってしまうためかと思います。

LIBPATH 導入の影響ですね.

:しちゃえば通るのですが、手抜きでない正しい直し方を教えてください。

--- ext/extmk.rb.in.orig	Fri Dec 22 15:51:09 2000
+++ ext/extmk.rb.in	Tue Dec 26 18:32:53 2000
@@ -372,3 +372,3 @@
     $libs = "@LIBRUBYARG@ " + $libs
-    $LIBPATH |= [$topdir]
+    $LIBPATH.unshift $topdir
   end