まつもと ゆきひろです

In message "[ruby-list:26856] Re: cgi.rb and Regexp::last_match"
    on 00/12/26, ARIMA Yasuhiro <fit0298 / fitec.co.jp> writes:

|意図が異なるなら、メソッドが増えても大丈夫かなあということで、
|atol() のように 0 を返す to_i に対して、strtol() のようにエラーをチェックする
|メソッドを用意するという方向で提案します。
|
|String#to_l() : Integer() が例外を返す局面で nil を返す
|String#to_d() : Float()   が例外を返す局面で nil を返す
|
|先だっての to_i? to_f? よりはいい名前だと思います。いかがでしょうか。

その提案の意図は理解できます。方向性には賛成です。が、to_lや
to_dでは(Rubyにlongやdoubleがない以上)、あまり良い名前でない
ように思います。単に

  (Integer(s) rescue nil)

で良いような気がするんですけど、そんなにchainしたいんですか?

                                まつもと ゆきひろ /:|)