わたなべです.

" たけ (tk)" <ggb03124 / nifty.ne.jp> writes:

:次のようなスクリプトで eval の例外が rescue にかからなかったです。
:
:ruby 1.4.3 (1999-12-08) [i386-cygwin] ではちゃんと取れていたのですが
:ruby-1.6.2-preview4.tar.gz では次のようになるようです。

1.6 では SyntaxError は StandardError のサブクラスではなくて,
ScriptError のサブクラスです.

-- 
わたなべひろふみ