わたなべです.

Katsuyuki Komatsu <komatsu / sarion.co.jp> writes:

:{tcl,tk}80.dll用とcyg{tcl,tk}80.dllを区別するために、
:    tcltklib80.dll
:    tcltklibcyg80.dll
:の2種類用意するとか。

ですから, いっぱい用意するのはもううんざりなんです.
最新だけに対応するという方向に持っていきたいというか…

先の代理 DLL はバイナリ互換がないと駄目なので Tcl7.6/Tk4.2
用の tcltklib.o を別にせざるを得ないという点でやっぱ没ですね.

どうせなら static に link しちゃうという手もあるかな.
って, そんな library はころがってないか.

:[ruby-talk:04158]でもなにか言われてますね。

TCL_LIBRARY, TK_LIBRARY を設定しない限り Tcl/Tk 自体動かない
ので, require して試してもあまり意味がないです.
#って誰か書いて.
registry を見ればいいのかもしれないけど.

-- 
わたなべひろふみ
FFIX やっと終わった