なひです.

> From: Yukihiro Matsumoto [mailto:matz / picachu.netlab.zetabits.co.jp]On
> Behalf Of Yukihiro Matsumoto

> |> |>   class Foo
> |> |>     def Foo.bar
> |> |> 	# class method
> |> |>     end
> |> |>   end
> |> |> 
> |> |> でいいのでしょうか ??  
> |> |
> |> |class Foo
> |> |  def self.bar
> |> |     # class method
> |> |  end
> |> |end
> |> |
> |> |の方がいい??
> |> 
> |> 私は前者の方が好みです。
> |
> |TMTOWTDIもいいですが,これに関しては魔法はないんですか?
> 
> まあ、なにか望ましいのがあれば、それをとりたてて使いやすくす
> ることが魔法になるわけですが、個人的にはどっちでも良いと思っ
> てるんで。定義したメソッドが(インスタンスメソッドでなく)クラ
> スメソッドになっちゃう構文とかあれば良いのかもしれませんが、
> いまんとこそこまでする気はないし。

なるほどー.

前者がちょっとイヤンなのは,Fooが二箇所に出てくるところですかね.
リファクタリング(単なるクラス名変更)が面倒だ!とか,
越水さんや高橋さん辺りが嘆いてみるとか.

class <<Foo 形式だと定義がバラバラになっちゃうし...
特に魔法がなければ,なひは後者にしとこうかなぁ.

# と,意識して選別できるものじゃありませんね本来なら > 魔法 ^^;