わたなべです.

Yukihiro Matsumoto <matz / netlab.co.jp> writes:

:|とすると
:|  Object::Socket::gethostname
:|を推奨したほうがいいかも.
:
:現状の::の定義ではこの表記のメリットはないですね。

ObjectSocket = Socket

module Net
  ...
  def Socket.method_missing(id, *args)
    ObjectSocket.send id, *args
  end

を足してたのを忘れてました.

:   require 'socket'
:
:   module Net
:     class Socket
:     end
:   end
:
:   include Net
:
:の状態で
:
:   Socket
:   ::Socket
:   Object::Socket
:
:はいずれも Net::Socket の方を指します。

::Socket と Object::Socket ぐらいは本当の TOP を指してもいい
と思います. てゆうかわたしもそうだと思ってました. じゃないと
わざわざ ::Socket と書く意味がないし.

-- 
わたなべひろふみ