小松です。

In the message of [ruby-list:22934] Cygwin + Ruby 1.4.4: function system fails
    on 2000/5/26 11:36:04 ito / htk.hitachi-cable.co.jp wrote:
> Windows98 + cygwin1-20.1 という環境で、
> ruby 1.4.4 (2000-04-14) [i386-cygwin]
> を使っていますが、次のような現象が発生して困っています。

Windows 98 + Cygwin B20.1でRubyを使う場合には、
cygwin1.dllを最低でもshanpshot-19990115のものに
入れ替える必要があります。

[ruby-list:19860]や、Cygwin情報
  http://www.jaist.ac.jp/~fujieda/cygwin/
の「Snapshot について」の「snapshot-19990115 (B20.1 向け)」の
ところを見てみてください。

可能なら、Cygwin CD 1.0かNet Release 1.1.xに切り替えましょう。

--
小松克行 / Katsuyuki Komatsu <komatsu / sarion.co.jp>