いがらしです。

At Thu, 27 Apr 2000 00:39:43 +0900,
in [ruby-list:22145] Ruby 1.4.3 と Ruby/GTK 0.23 の make に失敗,
Yasuhide Yano <yasuhi / he.mirai.ne.jp> wrote:

> make[1]: Entering directory `/usr/soft/inet/mail/sgmail/gtk-0.23/src'
> cc -fPIC -I/usr/local/lib/ruby/1.4/i586-linux -g -O2 -I/usr/lib/glib/include 
> -I/usr/local/include -DHAVE_XREADBITMAPFILEDATA   -c global.c -o global.o
> make[1]: Leaving directory `/usr/soft/inet/mail/sgmail/gtk-0.23/src'
> In file included from global.c:14:
> global.h:205: parse error before `*'

どうもGtkRcStyleが未定義でエラーになっているみたいですね。
GTK+のバージョンが古い(v 1.0.x)のかもしれません。
shell上で gtk-config --version を実行して確かめてみて下さい。

--
五十嵐  宏  (Hiroshi IGARASHI)