なかだです。

At Wed, 23 Feb 2000 03:01:25 +0900,
中村暁史 Nakamura Akifumi <BXQ04723 / nifty.ne.jp> wrote:
> > 現在のHash#update(other)では、HashオブジェクトselfにHashオブジェクト
> > otherをマージする機能を提供していますが、このマージの際に、selfとother
> > の両方に同じキーのエントリがある場合、otherの方の値で上書きすることに
> > なっています。この動作を変更し、同じキーのエントリがあった場合には
> > updateに与えられたブロックでどちらの値を選択するか決められるようにしま
> > せんか?
> 
> それって、updateとは違う名前にするほうが
> すっきりするなーと思ったです。
> 選択といっても、selfのほうの値を選択する時ってのはつまり
> update「しない」ことになるわけですよね。
> updateって一律全部updateしちゃうからupdateっていう
> (日本語になってないぞ俺)ようなきがします。

  納得。

> > otherをマージする機能を提供していますが、このマージの際に、selfとother

  そしたら merge でしょう、やっぱり。

  そういや Hash に "|" ってないですね。Hash を Set の代わりにするっ
て話も出てますが、そうなると∪や∩が必要かなという気もしますし。

-- 
そうだ 強気に ちょっと インチキに☆彡
    中田 "Bugるくらいがちょうどいいかも;-)" 伸悦