まつもと ゆきひろです

In message "[ruby-list:20892] Re: collect + find_all ==> select ?"
    on 00/02/21, "H.TAKEI" <takei.hideaki / lab.ntt.co.jp> writes:

|> というわけで、Enumerableクラスに「nil以外の要素を集める」と
|> いうメソッドを追加することに反対ではないです。しかし、その名
|> 前はcompactであるべきではないということですね。
|
|一応,名前の案を書いておきます。
|
|    名前案        機能
|=====================================
|    map_v            collect
|     (w/o block)    to_a
|
|    map_x            select
|     (w/o block)     Array#compact
|
|    map_vx           collect.compact

うーん、ご存知かどうか分かりませんが、私は相当名前にうるさい
です。んでもって v/x/vx は「分かる人にしか分からない」という
点で合格できないと思います。

|集合の要素は比較可能が前提でいい気がします。
|(STLもそのようですし。)

ごとけんさんは BitSet を推しているようですね。もっと議論が深
まることを期待します。

|#いまさらですが,本屋でruby本を立ち読みして,
| 『おぉ!』と感動して以来,まつもとさんのファンでした。
| 今回このように議論していただき,大ファンになりました。(^^;
| 陰ながら応援&布教活動に励んでおります。

感謝します。どーゆーところが良かったですか?

                                まつもと ゆきひろ /:|)