はじめまして,武井と申します。
くだらない事なので投稿をためらっていましたが,
思い切って投稿してみます。ちなみに初投稿です。

--

評価結果が nil のときは要素を削除する collect というのをよく使うので
この用途に select を定義しています。

===
module Enumerable
  def select
    collect{|i| yield(i)}.find_all{|i| i}
  end
end
===

要するに collect して find_all するだけです。

ところが,select って実はもう定義されていて,
find_all と同じだったのですね。

しくしく。

でも,この定義に select という名前をつけるのって結構いいと思うのです。
なぜかというと,

    1)select は,意味的に find_all と似ている。
    (標準の定義でも採用されているように)

ま,これはいいとして,注目はもう1つの方で,

    2)select は collect と最後の4文字が同じで似ている!


ということで,「名は体を表す度」が大変高いと思うのです。

みなさんどう思われますか?

--
takei.hideaki / lab.ntt.co.jp