渡辺哲也です。

いまごろですし、解決しない情報なのですが。

In message "[ruby-list:20394] ruby-1.4.3 port to HPUX 11.00"
    on 00/01/27, Yukihiro Matsumoto <matz / netlab.co.jp> writes:

|まつもと ゆきひろです
|
|HP-UX 11.0 ではRuby 1.4.3のcursesとfcntlがコンパイルできない
|そうです。なんでも $global$ というシンボルが未定義だとか。

gcc の環境がちゃんと動かないので、確認できませ
んでした。

HP C Compiler で ruby-1.4.3 については、make
test まで OK でした。HP C Compiler は、有料で
すから、持っていない場合もあるでしょうし。

ちなみに、次のようにして make しました。

$ CC="cc -Ae" CFLAGS=-O ./configure

# HP-UX 11 では、「-Ae」は省略可能のはずですが、
# 念のためにつけています。

--
WATANABE Tetsuya
 e-mail: Tetsuya_WATANABE / hp.com
         tetsu / jpn.hp.com