石橋秀仁です。あけましてお<ちょっとおそい

> > 添削っていうか, 御意見いただけないでしょうか?
> 
> Polynomial が Array を継承するよりも Array オブジェクト
> を Polynomial のインスタンス変数にする方が私は良いと思います.
> 
> 理由:
>   Array を継承するのはあくまで,実装の都合であって(ですよね?)
>   Polynomial は必ずしも Array すべての振る舞いを継承する必要
>   はない.

同意見です。継承と委譲のチョイス。

> あと,Array に to_poly メソッドを追加するよりは,
> 
>  p1 = Polynomial.new([1,2,3,4])
>  # または p1 = Polynomial.new(1,2,3,4)
> 
> みたいな書き方ができた方が直観的で個人的に好きです.

同感です。MatlabやOctaveという行列計算ソフトにも似ています。

Hideto ISHIBASHI
http://vip.cis.kurume-nct.ac.jp/~s34204/