草野です。
すいません。遅くなりましたが、報告です。

TADA Tadashi さんは書きました:
>ただただしです。
>
>kusano / mr-system.co.jp wrote:
>>ruby 1.4.3のソースをダウンロードして、WindowsNT4.0+cygwin b20.1上で
>>コンパイルしました。
>>しかし、make testを行うと、アプリケーションエラーのダイアログが
>>表示され、とまっってしまいます。
>
> cygwin1.dllのバージョン、もっと細かいところまでわかりませんか? 
>いつだかのsnapshotで、子プロセスの生成がダメダメだったバージョンが
>あったように記憶しています。最新版に変えてみると吉かも。
>
>#cygwin版のmakeはしたことがないので外しているかも知れません。

すいません。たださんがおっしゃる最新版がlatestにあるものだと勘違いして、
必死に何度もlatestからのバイナリをインストールしてました(^^;
snapshotから、cygwin1-19991225.dll.gzをもってきて現在のcygwin1.dllと
入れ替えたらうまくいったみたいです。

と、いうことで、ruby cygwin版をコンパイルする場合は、
・まず、latestから、開発環境一式であるfull.exeをインストール
・しかし、現在のlatestバージョンは子プロセス周りにバグがあるようなので
snapshotからcygwin1.dllの最新版をlatestからインストールしたcygwin1.dll
と入れ替える
で、やらないといけないようです。

----
Yoshiyuki Kusano  kusano / mr-system.co.jp