青山です。

On Fri, 17 Dec 1999 14:40:31 +0900,
Shugo Maeda <shugo / netlab.co.jp> wrote:

> > $> に content_type はちょっと気持悪い感じもしますけど、意味が通る気も
> > しますね。みなさんはいかがでしょう?
> 
> あ、mod_rubyの$>はApache::Requestオブジェクトなんです。
> erubyでもこれができた方がよいでしょうか。

はい。できるとありがたいのですが、ただ、$> を使うのはあまり嬉しくない
ような気がします。mod_ruby 上限定であれば、Apache::Request 等のような、
その環境に特有のインターフェイスを使ってもかまわないというか、そのよう
にした方がむしろ良いようにも思えます。

どうせ、nanika if defined?(MOD_RUBY) のようにして、mod_ruby だけに限定
する必要がある機能ですし、もう少し名前を考えませんか?


-- 
青山 和光 Wakou Aoyama <wakou / fsinet.or.jp>