まつもと ゆきひろです

In message "[ruby-list:19550] Re: String#shift?"
    on 99/12/16, Norio Suzuki <nosuzuki / e-mail.ne.jp> writes:

|この様なメソッドがあると便利だと思うことが多々あるので、標準となること
|に賛成です。

ううむ、なんとなくやりたいことは String#scan(/\w+/) でできちゃ
いそうな気がします。shiftってのがあっちゃだめってわけじゃな
いですけど。

>> a = "hahaha hihihi fufufu"
=> a.scan(/\w+/) {|w| p w}
"hahaha"
"hihihi"
"fufufu"

|ただ、shift と言うメソッド名に引っ掛かります。shift だと単純に 1キャラ
|クターずつ取れてくるというイメージです。

そーですね。配列との対比でいうとそういうイメージがありますね。
適切な名前が見付かれば採用できるかも。

                                まつもと ゆきひろ /:|)