こんばんは。鈴木教郎です。

> From: Kazuhiko Izawa <izawa / erec.che.tohoku.ac.jp>
> Date: Wed, 15 Dec 1999 22:36:26 +0900
>> Message-ID: <19991215223625A.izawa / erec.che.tohoku.ac.jp>

> 具体的にはsplit[0]を返して、残りの文字列を取り出したぶん詰めるというメソッ
> ドです。

この様なメソッドがあると便利だと思うことが多々あるので、標準となること
に賛成です。

ただ、shift と言うメソッド名に引っ掛かります。shift だと単純に 1キャラ
クターずつ取れてくるというイメージです。

> >> a = "hahaha hihihi fufufu"
> => "hahaha hihihi fufufu"
> >> a.shift
> => "hahaha"

ではなく、
>> a.shift
=> "h"
>> a
=> "ahaha hihihi fufufu"

と思います。

単純にメソッド名の問題なので、shift ではなく token か shift_word の方
が私には、ピンと来ます。
-- 
鈴木教郎
E-Mail: nosuzuki / e-mail.ne.jp