In message "[ruby-list:19278] オブジェクトの代入について"
    on 99/12/08, Hiroshi Saito <HiroshiSaito / pob.org> writes:
>もし、Integer#plus!(int)みたいなメソッドがあったならば
>
>a.itr do |i|
>    i.plus!(10)
>    print i, ","
>end
>
>とすれば、OKなんでしょうかね。

ただ、まつもとさんがmutableな数値をお嫌いのようなので、その
ような整数クラスは自作する必要があります ^^;;

ところで言語的にその辺こだわるなら、数値はすべて即値にすると
か数学的対象には型をつけるくらいまで行っちゃった方がスガスガ
しいとも思ってみたりするんですが僕の方が何か勘違いしてる気も
します。

mutableとimmutableを分ける基準ってなんですか??

-- gotoken