近永です。

以前報告した Readline.readline と trap の件ですが、
readline library を新しい version 4.0 のものにすると
解決しました。
readline-4.0 の CHANGES ファイルを読むと、
" Many changes to the signal handling:"
だそうです。

元のライブラリは 2.2 でした。
たぶんまだ 4.0 になっていない環境の方も多いのでは
ないかと思うんですが、
これだけのせいじゃないんでしょうか?
誰も同じ現象になってないみたいですけど……
それとももうみんなとっくに新しい libreadline になってるのでしょうか。
いちおう事の顛末を
	http://ha3.seikyou.ne.jp/home/hekitou/right_side/ruby/rl_signal.html
にてレポートしておきます。