いわおかです。

1 ヶ月ほど前に、ようやくバージョン 1.2.2 から 1.4 シリーズに上げた
ところ、extmath が動かないことに気づきました。最初はロードに失敗し
ているのかと思ったのですが、スタティックリンクのバイナリを作ろうと
して、関数名の変更にひっかかって動かないことがわかりました。

この件については、検索の結果 "[ruby-dev:4044] Re: static" で、ごと
けんさんが patch を出してるのを見つけて、無事動かすことができたの
ですが、この patch が元の extmath に反映されることは無いのでしょう
か?

# 反映させちゃうと、1.2 以前で動かなくなるという問題はありますが

また、こういう情報については、ruby-dev に入って無い限り、自分で探
すしか無いんでしょうねえ。

いわおか