青山です。

On Tue, 2 Nov 1999 00:11:43 +0900,
Wakou Aoyama <wakou / fsinet.or.jp> wrote:

> この気持はとても良くわかるのですが、それならば、例えば拡張ライブラリで
> も、require *.rb として呼び出せるようにするとか、やはり何かしらの対策
> は必要かと思われます。

これはさすがに気持悪いですね。発想を逆転して、何で書かれているかを意識
すべき、という方向にしても、*.so 以外にも *.dll だったりもしますから、
解決策にはなりそうに無いですね。

何か良い抜け道はないでしょうかね。2.14.4 では「jcode モジュールを
require すると」などと、完全に混乱しています。モジュールなら include
ですよね。require ならライブラリ。

気持はわかりますが、やはり先が心配です。


-- 
青山 和光 Wakou Aoyama <wakou / fsinet.or.jp>